WhosOn 2018

server help

Example on page

WhosOn 2018
Server help

Important
For WhosOn to work, you will need
to ensure that certain ports are
open in the firewall. With the default
setup for WhosOn, you would need
to open ports 80, 443, 8080 and
8443 for external chat and tracking,
and port 8011 for the WhosOn client
program to connect to the server.

WhosOn is designed to track visitors on your website in real-time and to allow operators within your organization to interact with
those visitors via live chat and proactive engagement. In addition to live visitor tracking, WhosOn also provides historical reporting of
visitor activity, chat sessions and operator activity. Below are the steps for installing and configuring WhosOn 2018.
Minimum system requirements:
• Windows Server 2008 R2 / 2012 R2 or higher
• SQL Server Express/Standard 2012 / 2014 / 2017
• At least 2GB RAM
• At least 40GB disk space
• IIS running .NET Framework 3.5 or higher
• ASP.Net 3.5 or higher
• Microsoft Redistributable C++ 2015 runtime
WhosOn can run on any physical, virtualized or cloud environment if the above criteria can be met.
We recommend not running any unnecessary programs on the same machine as WhosOn (other than SQL Server, when using a local
database) to ensure that WhosOn has access to the resources it needs and that its services and components are able to run correctly.
For WhosOn to work, you will need to ensure that certain ports are open in the firewall. With the default setup for WhosOn, you would
need to open ports 80, 443, 8080 and 8443 for external chat and tracking, and port 8011 for the WhosOn client program to connect
to the server.
Note: For performance and lack of conflict, it is recommended that WhosOn is installed on a standalone server.
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Access windows server manager and add the following roles
and features:

Web Server (IIS)
Common HTTP features
• Default document
• HTTP errors
• HTTP redirection
• Static content
Performance
• Static content compression
• Dynamic content compression
Security
• Request filtering
• Basic authentication
Application development
• .NET extensibility 3.5
• .NET extensibility 4.5
• Application initialization
• ASP
• ASP.NET 3.5
• ASP.NET 4.5
• ISAPI extensions
• ISAPI filters
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Features
Net framework 3.5
• .Net framework 3.5
• HTTP activation
• Non-HTTP activation
.Net framework 4.5
• .Net framework 4.5
• ASP.NET 4.5
WCF services
• HTTP activation
• TCP activation
• TCP port sharing
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Useful links
http://www.microsoft.com/web/
downloads/platform.aspx
https://www.iis.net/downloads/microsoft/url-rewrite
https://www.iis.net/downloads/microsoft/application-request-routing

ARR (Application Request Routing) is used, to have the chat and Gateway services run over the standard http and https ports (80 and
443) on a single IP. This is the recommended configuration for servers with a single IP address.

1

The following steps detail how to configure the WhosOn Gateway to run under the IIS 7.0+ (Windows Server 2012 and above) 		
ARR configuration. This is used when a server has only a single static IP address.

2

Open Internet Information Services (IIS) and access the top-level server. It will prompt to get started with the latest Web
Platform Components. Select ‘yes’ on that window.

Or navigate to: http://www.microsoft.com/web/downloads/platform.aspx to download and install the Microsoft Web Platform Installer.

3

The following Web Platform Installer application will need to be installed:

• URL Rewrite 2.1
• Application Request Routing 2.5
• Application Request Routing 2.5 with KB2589179
• Application Request Routing 3.0
You can use the following links to do so:
https://www.iis.net/downloads/microsoft/url-rewrite
https://www.iis.net/downloads/microsoft/application-request-routing
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Restart Internet Information Services (IIS) Manager and expand the web server. A Server Farms option will now be accessible.
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Right-click Server Farms and then click ‘Create Server Farm’.
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Give your new Server Farm a name. (We usually use the name ‘Gateway’, but this is not important.) Then click ‘Next’.
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For the Server Address, type in ‘localhost’. Check ‘Online’ and add, and then click ‘Finish’. You will then be prompted to add 		
a URL rewrite rule, click ‘Yes’.
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Within the new Server Farm options, go to Caching and uncheck ‘Enable disk cache’. Set the memory cache duration to 0. Also 		
select ‘Do not cache’ from the query string support drop-down.
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Go to Load Balance and set the Load Balance algorithm to ‘Weighted round robin’.
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10 Go to Routing Rules and check ‘Enable SSL offloading’.
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11 Go to Proxy and uncheck ‘Include TCP port from client IP’.
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12 Next, click on the top-level IIS node (the first item under Start Page). From here, select ‘URL Rewrite’ and modify the routing rule 		
that is in place. If one does not exist, add one. (The name of this rule isn’t important.)

Then, in the Match URL section, set the requested URL to “Matches the Pattern”. Set Using to ‘Regular Expression’ and set the Pattern
to: ^[^/?]*(\?.*)?$
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Important
If you have altered the application
names, you will need to modify the
pattern to the names you have given
the applications within the site.

13 Expand Conditions and add four rules, one for each of the WhosOn applications. The rules should be set up as follows:
Input		

Type				

Pattern

{REQUEST_URI}
{REQUEST_URI}
{REQUEST_URI}
{REQUEST_URI}

Does not Match the Pattern
Does not Match the Pattern
Does not Match the Pattern
Does not Match the Pattern

.*/chat$
.*/whosoncharts$
.*/newchat$
.*/settings$

If you have altered the application names, you will need to modify the pattern to the names you have given the applications within the site.
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Useful links
https://www.whoson.com/downloads

1

Download the WhosOn Installable Server 2018 from https://www.whoson.com/downloads.

Installation of WhosOn requires a SQL database to hold chat and visitor data. If you do not have your own instance of SQL server to
use, you will need to install SQL as part of the install process for WhosOn.
Follow the steps in the wizard to complete installation. Towards the end of the installation process, the installer will ask you
if you want to add inbound exceptions to the firewall on ports 8080 and 8011. Select ‘yes’. Then you can run through the final
steps in which you either enter the serial number you purchased for WhosOn or request an evaluation key allowing you to trial the
software for 30 days.

2

3
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After installation, open the WhosOn Service Manager software and it will request a password for the default ‘Admin’ user.
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Upon login you will be prompted to configure WhosOn database. In the wizard, select the SQL Database type to connect WhosOn to.
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Next you will tell WhosOn which computer your SQL server will be on and give it credentials for authentication. If you are
using the SQL Express 2017 edition installed with WhosOn (first choice in the installation wizard page on point 2), the instance
name defaults to SQLEXPRESS.
If you need to connect to a SQL instance on a separate machine, add the machine name or IP address before “\” followed by the
instance name. For example: mycomputer\SQLEXPRESS. If you are using an instance on the local machine, a full stop before “\” will
suffice. (As per the screenshot below.)
You can also choose which credentials to use to connect to the SQL instance: NT Authentication or a SQL user.
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Once it knows which SQL instance it needs to connect to, WhosOn will create a database for its data. Specify the name you 		
wish the database to take and the directory you wish it to reside in. (The defaults shown below.)
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Once the database is connected, the WhosOn services will automatically start. You can switch to the Server Log view to
monitor the services starting.
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You will see messages regarding the following services and tasks, as well as other general log messages:
Database connection – the database is required for WhosOn to work. If the database cannot be opened then WhosOn will not start.
Any errors here must be corrected in the database connection wizard or inside the database itself.
Metadata content – the metadata is a data file local to the server that contains information about your monitored sites.
Gateway connection – the WhosOn Gateway serves any web content required for WhosOn to work. This includes the ability to track
visitors and show the chat button on your pages.
WhosOn Query Service – the Query Service is the method used to read and write to the database. If this is stopped, it will not be
possible to view historic information from WhosOn or write new information to the database.
Now that WhosOn has a database account and the services are running, you will be able to access the settings portal and the WhosOn
client from the server itself. An external connection to the server will not be possible until the next section, IP/DNS Setup, is completed.
However, you will still be able to configure sites and user accounts and use the chat from the server.
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Once this is set up, open the WhosOn Service Manager. Go to File > Server Options > Visitor Tracking and set ‘Listen On IP 		
Address’ to the ‘127.0.0.1 On Software Loopback Interface’ option. Also change the ‘Listen For Page Tagging Web Requests On
Port’ to 80 and the ‘SSL Port’ to 443.

8
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Then, open Command Prompt with ‘Run as Administrator’ and enter the following commands:

netsh
http
add iplisten {Server IP}
Then press CTRL+C
net stop http
Answer Yes
iisreset

10 Now start the WhosOn Gateway from the ‘Service’ tab and check that it is working from the WhosOn Service Manager test page.
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11 To configure user accounts and site settings, you would need to log in to the settings portal. At this stage, the settings portal 		
will only be accessible via a browser on the WhosOn Server.

Settings portal

You can log in to the settings portal with your super admin credentials. Or, if you created a user account when running the Service
Manager for the first time, you can use that instead.

https://yourdomain.com/settings/
Login.aspx

Here you will be able to see the default site that was created for you, and you will be able to set up new sites and users if you require
them now. You can see the help guide for the settings portal, including how to set up site and users here.

Help files
https://www.whoson.com/help-files
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12 To see how the chat works, you would need to have a user logged into the WhosOn client. As with the settings portal, this 		

will only work locally from the server until the next setup section is completed. You can log in with any existing user profile but
bear in mind that your super admin profile cannot take chats.

To test the chat, you should log in with your admin profile, or any user you have created in the settings portal. When testing locally on
the server, you can use “localhost” for the server name. The Authentication String is found in the Service Manager under File > Server
Options > Chat Operators. To be available for a chat, a user would need to set their status to available, and it should be within the
opening hours for your site. (If you have set any in the settings portal.)
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13 Now that you have a user logged into the client, you can test the chat from a website visitor’s viewpoint. The Service Manager 		

contains a link to open your chat window, which will appear as it would to a visitor on your website. Click to begin the chat and
you will be able to pick it up from inside the client.
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Here you can see the test chat from both a visitor (on the left) and an agent point of view (on the right).
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14 With the chat up and running on your server, you can use the settings portal to make changes to the chat window and test

the results yourself without it being publicly available. Remember that for changes to take effect, any chats in progress should
be closed and any test pages you have open should be refreshed.
You may also test other features of WhosOn such as the web reports. You can load web reports from the Service Manager and access
with an existing user account.
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